UK:+44 1372 465000
Register | Login

Knowledge Base

Problems connecting to clients

This article applies to:
  • AB Tutor v7
  • AB Tutor v8

When a Discovery scan is run, the tutor machine sends a broadcast message out to its local subnet (and any additional addresses specified). Any client which receives this message will respond and the tutor then connects to them by IP address.

When you connect to a group, the tutor tries to connect to each computer in the group individually. To find them, it looks up their name with your DNS server to get the IP address and then connects to that IP.

If the DNS server reports the wrong (or no) IP address for that client, the connection will fail. This is what you're seeing currently. You can test this by pinging the client from the tutor, and using ipconfig to check the IP address the client has. If these IP addresses don't match, then you have a DNS problem.

To ping:

  • - open a command prompt on the tutor (start, run, cmd)
  • - type “ping <hostname>” where <hostname> is the name of the computer, as entered in the group.
  • - the 4 part number (10.0.0.1 in the example) is the IP address.
  • - this will give output like:
Pinging ict04.example.com [10.0.0.1] with 32 bytes of data:
Reply from 10.0.0.1: bytes=32 time<1ms TTL=127

To check the IP address with ipconfig:

  • - open a command prompt on the client (start, run, cmd)
  • - type “ipconfig”
  • - find the line that starts IP Address:
IP Address. . . . . . . . . . . . : 10.0.0.1 

These IP addresses should match. If not, you have a problem with your DNS server.

If it does match, the next step is to telnet to the client (from the tutor) on port 5151 and ensure you get the correct response. If this doesn't work, but the ping does, it's probably a firewall problem.

For more information, please see: http://www.abtutor.com/static/docs/ABTutorConnectionProblems.pdf or the manual appendices.